Back to overview
Degraded

Investigating Slowness Issues

Nov 18 at 03:21pm IST
Affected services
Claim Management System

Resolved
Nov 18 at 03:31pm IST

A fix was deployed, and the issue has been resolved.

Created
Nov 18 at 03:21pm IST

We are aware that users may be experiencing system slowness. Our team is actively working to resolve the issue as quickly as possible.