Back to overview
Degraded

Reports and Dashboards service is down

Aug 28 at 02:24pm IDT
Affected services
Claim Management System

Resolved
Aug 29 at 11:43am IDT

The reports and dashboards service is restored.

Created
Aug 28 at 02:24pm IDT

The reports and Dashboards service is down. We are working to resolve the issue.