Back to overview
Degraded
Telephony issue
Jul 23 at 05:02pm IDT
Affected services
Claim Management System
Resolved
Jul 23 at 06:17pm IDT
The Telephony system is now operating normally.
Affected services
Created
Jul 23 at 05:02pm IDT
Twilio reported an issue that may impact the ability to make or receive calls. They are working on resolving it
Affected services