Back to overview
Degraded

Slowness and page refresh

May 23 at 02:56pm IDT
Affected services
Claim Management System

Resolved
May 23 at 03:31pm IDT

We have deployed a fix, and the system is back to normal.

Created
May 23 at 02:56pm IDT

Users may experience slowness and page refresh issues. We are working on resolving it.